Contents

Articles

Basic User Tasks (Patient)  1
  Start Up the Chair  1
  General GUI  6
  Using the Drive Modes  9
  Shut down the Chair  13
  Recharge the Chair  17
  Move by Pushing  18
  Re-enable the Motors an Emergency Stop  19

Intermediate Administrator Tasks (Doctor/Therapist)  22
  Connecting to the Chair from your PC  22
  Opening MobileEyes  26
  Localizing the Robot  27
  Using MobileEyes for Driving  29
  Changing Maps in MobileEyes  30
  Enabling/Disabling Goals on the Chair’s Interface  32
  Connecting with X-Windows  35

Chair Guru Tasks (Administrator/Developer)  37
  Creating a New Map  37
  Creating New Goals on the Map  44
  Changing Parameters in MobileEyes  49

Help  51
  Troubleshooting  51

References
  Article Sources and Contributors  53
  Image Sources, Licenses and Contributors  54
Basic User Tasks (Patient)

Start Up the Chair

To start the robot
This tutorial discusses the start up and log in process of the wheelchair.

Disconnect the robot from power supply
1. Remove the plug from the wall socket
2. Disconnect the black and red wires at the conjunction by gently pulling them apart.

IMPORTANT: If you do not completely remove the power cord from both the wall socket and the wheelchair, the wheelchair will not properly charge when it is plugged back in.
**Turn on the robot**

1. Remove the deadman’s switch by turning the ring on the bottom of the lower cap in a counterclockwise direction and pulling the mechanism up.

2. Push the green button at the back to turn on the robot.

3. Replace the tape end of the deadman’s switch on the socket and tighten the cap.
• Place the cap over the socket and turn in a clockwise direction until the switch "settles" down into the socket.
  Tighten the cap completely, by turning it clockwise.
4. Press the black button labeled 'comp on' to turn on the robot's computer.
• This button is above the green button on the back of the robot
5. You will hear the motors start running and the touch screen will automatically turn on.

6. Wait for the login screen to appear, as booting takes some time.
Log in

1. Using the keyboard, log in.
   - For now use the username "dan" with the password "dan" and hit 'Return' on the keyboard.
2. A dialogue box showing the progress of initialization will appear.

IMPORTANT: If you look up at the upper sensor, you see the lights in the sensor, will turn from green to red, when initialization starts. If initialization is successful, the light will turn green again after some time.
Also, when the initialization progress bar reaches around 50% or 60%, you will hear a distinct click from the laser finder. Listen for the click; if the sensor does not click, it may not have initialized properly.

- If the laser finder fails to initialize, check that the sensor connections are properly connected.

3. Upon completion of the log in and initialization sequence, the Main Icon Menu will appear.
General GUI

This tutorial describes some of the information given in the GUI. It is assumed that you have turned on and logged into the chair.

Speed, Battery, and Status

- The bottom right part of the touch screen shows information about the state of robot, like speed and battery information.
- These bars are not very reliable at showing the accurate state.
- To get a more accurate idea of battery voltage, take a look at the display, which is on the top left of the computer case.
• The text on the bottom left of the touch screen notifies the user about the motion of the robot.
  • For example, you can see whether the robot is moving, stopped, arrived at goal, failed to go to a goal, lost, the emergency stop is engaged, or the motors are disabled.
  • The box in the top left of the screen labeled "Select" sends you back to the main screen, where you may pick a drive mode.
Under the Hood

- Touching the capital 'M' at the bottom right of the screen, reveals the Menu bar at the top of the screen as shown in the picture above.
- Pressing 'Users' gives a list of users who can log into the robot.
- 'Look&Feel' lists options that can change the interface of the robot.
- 'Robot' holds system information.

For now, we highly recommend the user not to use the Menu bar without the help of a technician and that the technician not make changes directly on the robot. Instead, changes should be made in Mapper3 and MobileEyes and uploaded to the robot when possible.
Using the Drive Modes

Drive Modes
This tutorial discusses navigating the GUI and accessing the drive modes of the wheelchair. It is assumed that you have turned on and logged in to the chair.

Choosing a drive mode
- To drive the robot, the user needs to choose a drive mode; the drive modes are described below.
- The drive mode options can be found on the Main Icon Menu.
  - To choose a drive mode, touch the appropriate icon on the touchscreen.
Express Drive
Takes the user to a preset goal while avoiding obstacles.
To use Express Drive:
1. Choose the goal by touching the appropriate icon.

2. Use the yellow arrows to navigate upwards or downwards to find goals.
3. To return to the main menu and choose a new mode, use the ‘Select’ icon. Sometimes the smiley face representing the goal (as shown in the figure above) may not appear, in which case the goal will be represented by an empty labeled box.
Smart Drive

Allows the user to drive the robot using the arrows while the on-board computer prevents the chair from bumping into obstacles. This mode could be used to "train" patients to drive power chairs.

To use Smart Drive:
1. Touch the arrow that points in the direction you wish to go.
   - Up arrow takes robot forward.
   - Down arrow takes robot backward.
   - Right arrow turns the robot towards the right.
   - Left arrow turns the robot towards the left.
2. Note that the blue outline shows which arrow is currently selected.
3. To return to the main menu and choose a new mode, use the 'Select' icon.
Manual Drive
Allows the user to drive the robot using the arrows without any intervention by the on-board computer.
1. When Manual Mode is chosen, the following message will be displayed. To go into Manual Mode, choose OK.

2. Touch the arrow that points in the direction you wish to go.
   - Up arrow takes robot forward.
   - Down arrow takes robot backward.
   - Right arrow turns the robot towards the right.
   - Left arrow turns the robot towards the left.
3. To return to the main menu and choose a new mode, use the 'Select' icon.
Shut down the Chair

Shutting Down the Chair

This tutorial assumes that the chair is turned on and logged in.

1. To quit from anywhere in the user GUI, type <ctrl + q> on the keyboard.

2. A dialog box will pop up reading, "Server disconnected". Touch the "Quit" button. If touch screen doesn't work, use the mouse for now.
3. When the login screen reappears, select "Actions" from the bottom of the screen using the mouse. The computer may take a moment to respond to this click.

4. In the resulting popup, select "Shut down" and select "OK".
5. A lot of text will appear on the screen.

6. When "Power down." appears at the bottom of the text, press the "Robot Off" button on the top of the computer case on the back of the robot.
7. Connect the battery back to the wheelchair. Connect the plug of the battery to socket on the wall, to keep the chair charged.
Recharge the Chair

Recharging the Wheelchair
1. Reconnect the charger to the wheelchair.
2. Plug the charger into the wall socket.
Move by Pushing

Move by pushing

In the event that you need to physically move the wheelchair, you must first disengage the motors.

- Pull the handle outwards and turn clockwise to disengage the motors.
- It will end in a vertical position, pointing down.
- This movement requires considerable force.
- Now the chair can be pushed like a regular wheelchair.
- This is guaranteed to result in the chair being lost in the map; you will have to re-localize the chair.
- To re-engage the motors, turn the handle counterclockwise until it is back in its original position, as shown in the picture.
Re-enable the Motors an Emergency Stop

Relieving the Emergency Stop
When the emergency stop is pressed, you will see this screen on the chair:
Re-enabling the motors with MobileEyes

1. Turn the emergency stop button in the direction indicated on the button until the button pops up again.
   - The screen on the chair will display the message "E-Stop relieved but motors still disabled" at the bottom.

2. Click "Enable" in the dialog box in MobileEyes.
Re-enabling the motors without MobileEyes

1. Turn the emergency stop button in the direction indicated on the button until the button pops up again.
   - The screen on the chair will display the message "E-Stop relieved but motors still disabled" at the bottom.

2. Press the "Joystick Direct" button on the back of the chair twice.
Intermediate Administrator Tasks
(Doctor/Therapist)

Connecting to the Chair from your PC

Connecting to the wheelchair

This tutorial assumes that you have turned on and logged in to the wheelchair.

This tutorial was written on Windows XP, however the steps outlined below should be easily adaptable to Windows Vista and Windows 7.

IMPORTANT: Using Dan's laptop at Spaulding, you need only complete steps 6 and 7 (see section 1.1); the other steps are already completed for you.

1. Click on the wireless network connection icon in the right side of the menu bar. This icon may be hidden, if so click the little "(<)" icon to display it. If you cannot find the icon in the menu bar, go to Control Panel in the Start menu and choose "Network and Internet" (and then 'Network and Sharing’ in Vista).
2. In the resulting window, click "Change advanced settings" (or "Manage Wireless Network" for Vista).

3. In the Properties window, highlight "Internet Protocol (TCP/IP)" and hit "Properties".

4. Select "Use the following IP address:" and enter the IP address 192.168.10.X with the subnet mask 255.255.255.0. Click "OK".
   - Replace X with a unique number. 224 is reserved for the chair itself; any other number will do, provided another user is not using it simultaneously.
5. You will be returned to the Properties window. Click “Close”. 
(Spaulding users start here)

6. This returns you to the desktop. Open the wireless network connections again, as in step 1.

7. In the list of the available networks, locate the one called "wheelchair". Double click on it. A dialog box will tell you that the computer is connecting to wheelchair, which will disappear when the connection is completed.
Testing/Troubleshooting the connection

1. Open the program Command Prompt.
2. Type "ping 192.168.10.224" and hit enter.
3. If packets are returned, you have successfully connected to the wheelchair. If the request times out:
   • Ensure that the chair is turned on. Consider disconnecting your PC from the wheelchair network and restarting the chair. Follow the directions at the top of the page again.

Note

When you are ready to reconnect to the internet:

1. Follow steps 1-3 in "Connecting to wheelchair".
2. Instead of selecting "Use the following IP address:", select "Obtain an IP address automatically." and click OK in that window
3. Follow steps 5 and 6 in "Connecting to wheelchair".
4. Double click the desired network.

Opening MobileEyes

Opening MobileEyes

This tutorial assumes that you have logged in to the chair and that you have connected to the wheelchair network

• Once the PC is connected to 'wheelchair' server, click on the MobileEyes icon to open MobileEyes. The following dialogue box will appear:

   - There is no need for username or password, however the "Robot Server" must be set to 192.168.10.224
   - Click 'Connect'. It will take a few seconds to connect to the robot.
Localizing the Robot

Localizing the robot using MobileEyes

This tutorial assumes that you have opened MobileEyes and that a map exists on the robot (see creating a map and/or changing the map).

- Once MobileEyes is open, you can see the robot as a red blob on the map (given that no new map is being used for the first time). The black line on the red line shows the direction the robot is facing if it has been properly localized. Whatever the robot senses will appear as light and dark blue dots.

- At the top left corner, there is a button 'Localization'. Click it. Alternatively, you can also go to 'Tools' in the menu bar, select 'Robot Tools' and then click 'Localize To a Point'.

- The Localization box will appear.
• The Localization box shows the percentage of localization and has two buttons: 'Localize to a Point' and 'Done'.
• Click 'Localize to a Point'. The cursor will change form.
• Move the cursor to the place on the map (on the screen), where the robot is currently located.
• Press down the left mouse button and drag the mouse in direction the robot is actually facing. The change in percentage localization will be shown in the Localization box. Keep adjusting until the percentage localization is 50 or above. Once the percentage is 50 or above, click 'Done'.
• If localization has been done correctly, the black line on the red blob should be facing the dot that represents you on the map, if the robot is physically in front of you. Now the robot is ready to be driven via MobileRobots.

Using MoblieEyes for Driving

Driving via MobileEyes
This tutorial assumes that you have opened MobileEyes and localized the chair.

Before driving the chair remotely, magnify and center the map using the 'Magnify' and 'Pan' buttons. These two buttons are marked with red arrows in the picture above. Clicking 'Pan' will show a panning box, outlined in red, with four arrow buttons that can be used to move the map within the window.

As you drive the robot around, you will be able to see it moving around on the map.

If you want to stop the robot suddenly while driving, click the 'Stop' button on the upper left corner of the screen. The Status bar shows what the robot is doing right now; for example, 'Stopped', 'Arrived at a goal', etc. The Mode bar shows whether the chair is operating in 'Safe' or 'Unsafe' (manual) drive mode.
To Drive Manually
Click the 'Drive' button, which is marked with a green arrow in the picture above. The Drive box, outlined in green, will appear. Use the up and down arrows in the Drive box to go forward or backward, and the left and right arrows to turn left or right.

To Drive using Safe Drive via MobileEyes
Click on the 'Safe Drive' button, pointed to by the purple arrow, and drive as you would drive it manually.

Sending the robot to a goal
The goals for the map are listed at the bottom left corner of the screen, and are circled in purple in the picture above. Double-click the name of the goal to send the robot to the goal. Alternatively, you can select the name of the goal and click the 'Go To' button.

Changing Maps in MobileEyes

Changing Maps in MobileEyes
This tutorial assumes that you have opened MobileEyes.
• Go to 'Tools'.
• Select 'Robot Configuration'.
• Set Parameter Priority to Expert.
• Select 'Files' from the list shown in the 'Sections' column.

The same *.map file must be specified in both 'Map' and 'LaserLocalizationMap'.

- For each option, click on the button labeled ‘...’. A list of maps and other folders stored on the robot will show up.
  Select the desired map and click ‘Open’.
- Make sure to do this for both ‘Map’ and ‘LaserLocalizationMap’.

- Click ‘Ok’.
- MobileEyes will remind you that you have modified the robot’s settings, which is to be expected. Click OK.
- Before setting the goals on the wheelchair interface, restart the wheelchair.
Enabling/Disabling Goals on the Chair's Interface

Opening the Goals

This tutorial assumes that you are either logged in on the chair or logged in via X11. This tutorial may be done either directly on the chair or while remotely logged into the chair via X-windows.

1. Click/Press on the "M" button at the bottom right corner of the screen.

2. This opens the menu bar at the top of the screen.
3. Select "Look and Feel" and then select "Goal List...".

Disabling Goals
1. Click the box next to the goal you wish to remove from the Express screen, so that the check mark in the square disappears.
Adding/Enabling Goals

1. In the pulldown menu on the next blank line, select the desired goal.

2. In the next input field, input the name you would like to appear on the Express screen.

3. If you have a desired icon for this goal, put the full path in the next field.
4. Make sure the "Enabled" box is checked.
5. Make sure that the blank line directly after all of your goals is enabled as well.
6. Select "Apply", then "OK".
7. Click the at the bottom right "M" again to hide the menu.

---

Connecting with X-Windows

Connecting to the Chair with X-Windows

This tutorial assumes that you have turned on and logged in to the chair and connected to the wheelchair network. Please note that this tutorial was developed with a Macintosh, and that the process of connecting to the wheelchair network on the Mac is not currently documented.

X-Windows is a service that allows you to access the wheelchair GUI on your PC. To connect using Windows, you will use a program called Xming, and on a Mac you will use a program called X11.

Using X11

1. Log in to the wheelchair via ssh using the program called X11.
   
   ```
   ssh -X username@192.168.10.224
   ```

2. Enter your password when prompted.

3. You must add to your **LD_LIBRARY_PATH** to avoid the error message "cannot open shared object file for libswift.so.3".

   ```
   export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/home/reed/AriaInternalLibs/lib
   ```

   - The above could also be added to your login script so that it happens upon login.

4. Then start the Wheelchair client program with ./Wheelchair

   - To do steps 3 and 4 in one step, enter
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/reed/AriaInternalLibs/lib;
/usr/local/Wheelchair/bin/Wheelchair

For example:

```
bash-3.2$ ssh -X dan@152.260.10.224
Password:
Warning: untrusted YDK forwarding setup failed: xauth key data not generated
Warning: No xauth data, using PAM authentication data for YDK forwarding.
Linux Wheelchair 2.4.26 #9 SMP Fri Nov 12 15:26:37 EST 2004 1686

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Nov 15 16:24:52 2010
dan@Wheelchair1:~$ export LD_LIBRARY_PATH=LD_LIBRARY_PATH:/home/reed/AriaInternalLibs/lib; cd /usr/local/Wheelchair/bin/; ./Wheelchair
```

### Using Xmim

Xming is a GUI front-end for X-Windows. Xming allows access to the wheelchair GUI from your PC. There have been issues using Xming to access the robot.

To access the robot’s touch screen from a laptop or PC:

1. Start Xming by clicking on the icon. There will be no visual message or dialogue box that will confirm that Xming has started.
2. Start PuTTY. In the configuration box, choose to connect to wheelchair’s server.
3. Then login into the robot using ‘dan’ as both username and password.
4. You must add to your **LD_LIBRARY_PATH** to avoid the error message "cannot open shared object file for libswift.so.3".

```
export LD_LIBRARY_PATH = SLD_LIBRARY_PATH:/home/reed/AriaInternalLibs/lib
```
5. Change to the directory that holds the Wheelchair program

```
cd/usr/local/Wheelchair/bin
```
6. Start the wheelchair program with either

```
./Wheelchair
```
or

```
./Wheelchair -user dan -server "localhost" -readIni -writeIni –globalScope
```
Chair Guru Tasks
(Administrator/Developer)

Creating a New Map

Creating a new map
This tutorial assumes that you have connected to the wheelchair and opened MobileEyes.

Making Map
1. Open MobileEyes.
2. Click on 'Tools' in the Menu bar and select 'Map Creation' -> 'Start Scan' from the drop down menu.
3. MobileEyes will prompt the user to name the new map that will be made. Enter a name and hit 'OK'.
4. MobileEyes will notify you that the robot is about to make a map. Hit 'OK'.

5. Use either the Manual Drive Mode, the joystick, or MobileEyes to drive the robot around the area that you want to map. To prevent the laptop which has MobileEyes open from disconnecting from the wheelchair server, it is best to keep the chair and laptop near each other when driving the chair around.

6. Once you are done mapping the area, go to 'Tools' -> 'Map Creation' -> 'Stop Scan'.
   - If while mapping the area, the laptop disconnected, then close and reopen MobileEyes and carry out step 6.
7. MobileEyes will ask whether you are done mapping. Hit ‘OK’ if you are done.
Editing the map

1. Open Mapper3.

2. Go to 'File' -> 'Open on Robot' -> '192.168.10.224'. If a dialogue box appears, then ensure that the username is 'dan' and robot server is 192.168.10.224 and insert password 'dan'.

3. A list of files that are saved on the robot's computer will appear. Find the map you just created (*.high) and hit 'Open'. 
4. Wait while the map is loaded and the program performs compare, adjust, and align. Once the computer is done loading, Mapper3 will notify you that 'Registration is Complete'. Click 'OK'.

5. You will be prompted to save the unedited map in the computer you are currently working on. Note the name of the map: it will be of form '*_high'. Click 'Save'.

6. For quick rough clean, click 'Clean' in the 'Scan Tools' bar. Once that's done, click 'Finish' in the 'Scan Tools' bar. The computer will ask if you want to save the changes, hit 'Yes'.
7. The map needs to be further cleaned up by erasing any remaining unwanted lines, drawing in any desired forbidden lines and add goals, etc. This can be done by using the tools in the menu near the top of the screen.

- Make sure all of the walls are fully complete, and that there are no gaps in the map where there is a wall in real life. Close any gaps with forbidden lines.
- IMPORTANT: The wheelchair cannot differentiate between the top of a stairwell and open floor space. MAKE SURE that you block off any stairs with forbidden lines.
- Erase any doors that appear in the map.
8. (Optional) To save a copy of the map on your computer, go to 'File' -> 'Save'.
9. (Very Important) To save the map on robot, go to 'File' -> 'Save on Robot' -> '192.168.10.224'. The map will be saved as '_high.map'. Hit 'Save'.

10. Mapper3 will ask whether you want the robot to use this map or not. Depending on what you need, hit 'Yes' or 'No'.
   - VERY IMPORTANT: If you choose 'Yes', please refer to the "Changing maps in MobileEyes" tutorial for details on how to change the map. Selecting 'Yes' changes the map for only one of the two options.
Creating New Goals on the Map

Setting new goals

This tutorial assumes that you are connected to the wheelchair.

1. Open Mapper3.
2. Navigate to "File">"Open Robot">"192.168.10.224".

3. Log into the robot.

4. Choose the relevant map file. This file will have the extension ".map".
5. Mapper3 will communicate with the robot.

6. When the map appears, click the "Goal" icon in the upper toolbar.
7. Click in the map where you would like the goal to be.

8. A dialog box will pop up. Enter a name for the goal, and leave the type as "Goal". Click "OK".

9. Repeat steps 7 and 8 for each desired goal.

10. When you are finished, navigate to "File"->"Save on Robot"->"192.168.10.224".
11. A dialog box will pop up. Keep the same file name, and press "Save".

12. Restart the robot for the new goals to show on the touch screen.

13. You can now close Mapper3, and switch the map on the chair to this version of the desired map.
Changing Parameters in MobileEyes

This tutorial assumes that you have connected your PC to the chair, and that you have opened MobileEyes.

1. Navigate to "Tools" > "Robot Configuration".

2. Choose the level at which you want to work.
3. Choose a parameter to change:
   • For parameters relating to Express Drive, use the parameters in "Path Planning" in the sidebar.
   • For parameters relating to Smart Drive, use the parameters in "Teleop" in the sidebar.
   • For parameters relating to Manual Drive, use the parameters in "Robot Config" in the sidebar.

4. Parameters can be changed by replacing the old value in the box on the right with the new value, and clicking "OK".
Help

Troubleshooting

Continuous beeping during startup, before login window
• Make sure all peripherals are plugged in, especially the mouse and keyboard, if applicable!

Strange behavior from the chair
• Check the charge level.

Initialization fails after login
• Check the connections of all sensors, especially the low laser in front.
• Check to see that the low lasers are receiving power (little green LED on the top of the sensor).
  • If they are not powered, check the power board pin to ensure the pin is still giving 5V of power.

Robot coasts to a stop
• The touchscreen-based, as well as the MobileEyes Stop button uses the Teleoperation deceleration parameter to stop the wheelchair. For a more aggressive stop, change that value through MobileEyes’ Robot Configuration menu option under the Teleoperation section.
• Alternatively, when you release the deadman, the Stop button doesn't work because it disengages the motor drivers, but does not set the brakes. Accordingly, the chair should glide to an entropy-driven halt, not by motor-based deceleration. If there truly is a bug in the controls and it continues driving rather than coasting, let Bill know.

Chair is displaying irrational behavior, and you fear to move it
• There is a lever beneath the seat accessible from the back that when pulled towards the back and rotated clockwise 90 degrees, disengages the motors from the wheels so that you can easily push the chair around.
  • This is, however, guaranteed to result in the chair being lost in the map.

Goal created in Mapper3 does not appear in user goals
• On the chair GUI, bring up the menu.
• Look and Feel > Goal List
• Pull down the goal you would like to add, and name it. Select ok.
• Verify that the goal show up in the Express mode goal list.
If motors fail to engage

- You may also notice that "E-stop enabled (engaged?)" is displayed at the bottom left of the touchscreen
- Check the red emergency stop buttons. One is located on the panel below the touchscreen, near the joystick, the other is located on the back of the chair, on top of the computer.
- If one (or both) of the buttons is pushed down, the motors will not engage.
- To reengage the motors, turn the button(s) so that it pops back up and "E-stop relieved" appears at the bottom of the touchscreen.

If your PC won't connect to the chair

- Check your TCP/IP settings
- If that doesn't work:
  - Log in, and log out of your PC
  - Try again
- If that doesn't work:
  - Restart your PC
  - Try again
- If that doesn't work:
  - Log in and out of the chair
  - Try again
- If that doesn't work:
  - Restart the chair
  - Try again
- If that doesn't work:
  - Shut down the chair and the PC and restart both.
  - Check your TCP/IP settings
  - Try connecting again
- If that doesn't work, contact us
Article Sources and Contributors

Start Up the Chair  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=977  Contributors: AbbyDray, MelissaFrechette, RitikaShamsuddin


Shut down the Chair  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=965  Contributors: AbbyDray, AudreySidohn, RitikaShamsuddin

Recharge the Chair  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=967  Contributors: AbbyDray, MelissaFrechette


Re-enable the Motors an Emergency Stop  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=882  Contributors: AbbyDray

Connecting to the Chair from your PC  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=971  Contributors: AbbyDray, MelissaFrechette, RitikaShamsuddin


Enabling/Disabling Goals on the Chair’s Interface  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=926  Contributors: AbbyDray


Creating a New Map  Source: http://wiki.cs.mtholyoke.edu/mediawiki/人们对/index.php?#id=973  Contributors: AbbyDray, AudreySidohn, MelissaFrechette, RitikaShamsuddin


